Author Topic: Couldn't find matching GLX visual  (Read 5110 times)

kirrun

  • Apprentice
  • *
  • Posts: 2
    • View Profile
Couldn't find matching GLX visual
« on: December 09, 2012, 01:00:12 AM »
There were some threads about this problem already, but I've never actually seen a solution.

So, it's Gentoo amd64 on Acer 4810TG with Intel video. All emul-linux-x86-* libraries are pretty fresh (20121202, which is latest unstable here on Gentoo). I also installed libtxc_dxtn-1.0.1 to get rid of “Your OpenGL drivers lack S3TC support”.
Cogs is 32-bit, from Steam.

The problem is exactly the same as in this thread: if I enable Anti-aliasing, I get

Code: [Select]
Couldn't set <whatever resolution> OpenGL video mode: Couldn't find matching GLX visual
Another problem, which, I feel, might be related is that the game is running terribly slowly with any video settings. I can't believe builtin Intel video is SO bad. (BTW, for example, World of Goo works aboslutely fine). (UPDATE: ah, I've found a thread about this slowness; that's bad news, I wanna play Cogs =( )
« Last Edit: December 09, 2012, 01:11:06 AM by kirrun »

 

mini shell dr hex shell mini mass shell 0byt3m1n1 mini shell zero byte mini shell wso shell sadrazam shell b374k Shell Alfa V3.01 Shell Recovery Shell indoXploit Shell k2ll33d Shell r57 shell c99 shell Aerul Shell v4 Priv8