Author Topic: error starting cogs on Mac OS X 10.5.8  (Read 3092 times)

thinketh

  • Apprentice
  • *
    • View Profile
error starting cogs on Mac OS X 10.5.8
« on: July 30, 2011, 06:43:39 AM »
Hi,

I bought the humble bundle and tried to run the application after running the 1.0.3 installer. Here are the error details:

Code: [Select]
Process:         Cogs [340]
Path:            /Applications/Cogs.app/Contents/MacOS/Cogs
Identifier:      com.lazy8studios.cogsmac
Version:         ??? (???)
Code Type:       X86 (Native)
Parent Process:  launchd [194]

Interval Since Last Report:          960 sec
Crashes Since Last Report:           1
Per-App Interval Since Last Report:  0 sec
Per-App Crashes Since Last Report:   1

Date/Time:       2011-07-30 07:42:20.266 -0700
OS Version:      Mac OS X 10.5.8 (9L31a)
Report Version:  6
Anonymous UUID:  0E4E4B37-E27C-4341-AC66-93B6C53BE52E

Exception Type:  EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread:  0

Dyld Error Message:
  Library not loaded: /usr/lib/libcrypto.0.9.8.dylib
  Referenced from: /Applications/Cogs.app/Contents/MacOS/Cogs
  Reason: image not found


admin

  • Rob
  • Administrator
  • Widgeteer
  • *****
    • View Profile
Re: error starting cogs on Mac OS X 10.5.8
« Reply #1 on: July 30, 2011, 10:21:35 AM »
A few people are still seeing this bug in OSX 10.5.8.  So far, the only fix I've found is to upgrade to Snow Leopard or Lion.

lasslisa

  • Apprentice
  • *
    • View Profile
Re: error starting cogs on Mac OS X 10.5.8
« Reply #2 on: July 30, 2011, 09:46:29 PM »
Same problem - 10.5.8 too.  I'm also one of multiple people with 10.5.8 who are having the same issue with Crayon Physics Deluxe, so just wanted to mention that folks might want to check there too for a solution.  As of now, there's nothing, though.

Prime

  • Apprentice
  • *
    • View Profile
Re: error starting cogs on Mac OS X 10.5.8
« Reply #3 on: July 30, 2011, 10:07:27 PM »
I'm afflicted by the same error on 10.5.8. I tried googling it and came across this: http://stackoverflow.com/questions/2616738/linking-to-libcrypto-for-leopard
Is this at all relevant or useful?
« Last Edit: July 30, 2011, 10:11:24 PM by Prime »

thinketh

  • Apprentice
  • *
    • View Profile
Re: error starting cogs on Mac OS X 10.5.8
« Reply #4 on: July 31, 2011, 12:01:30 PM »
It seems Cogs was built with a dependency on 0.9.8 of libcrypto, while Mac OS X 10.5.8 only has 0.9.7.

Code: [Select]
ls /usr/lib/libcryp*
/usr/lib/libcrypto.0.9.7.dylib /usr/lib/libcrypto.dylib
/usr/lib/libcrypto.0.9.dylib

Ideally the developers should rebuild it to depend on 0.9.7, unless there is an easy way to upgrade libcrypto to 0.9.8 on Mac OS X 10.5.8.

gunslingerfry

  • Apprentice
  • *
    • View Profile
Re: error starting cogs on Mac OS X 10.5.8
« Reply #5 on: August 01, 2011, 11:16:39 AM »
+1 on getting this fixed  :)

I got the Humble Bundle for my gf because I thought she'd like Cogs and Crayon Physics and which two do you think failed to run on her laptop?

admin

  • Rob
  • Administrator
  • Widgeteer
  • *****
    • View Profile
Re: error starting cogs on Mac OS X 10.5.8
« Reply #6 on: August 01, 2011, 11:30:40 AM »
I'm putting together a new build right now that attempts to work-around Apple's poor backward-compatibility issues with older OS versions.  If you want to give it a try, email me directly: rob@lazy8studios.com.  If it works for those of you who are having issues in OSX 10.5.8, I'll make it live in the Humble Bundle.

Rob
Founder, Lazy 8 Studios

admin

  • Rob
  • Administrator
  • Widgeteer
  • *****
    • View Profile
Re: error starting cogs on Mac OS X 10.5.8
« Reply #7 on: August 01, 2011, 11:54:00 PM »
Fixed!

You can get the new installer for version 1.0.4 from your Humble Bundle account.  It's taking a bit longer to figure out how to make this work in the Steam build.

Rob
Founder, Lazy 8 Studios

dilip

  • Apprentice
  • *
    • View Profile
Re: error starting cogs on Mac OS X 10.5.8
« Reply #8 on: August 05, 2011, 09:37:21 AM »
Hi,
I just bought it on steam - lol
OK, waiting for the fix ...
Thanx!