Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - petelewis

Pages: [1]
1
Cogs / Re: Getting opengl errors on linux.
« on: July 28, 2011, 01:05:09 PM »
Sounds encouraging, Rob. Do you have a list of which 32-bit drivers/libraries we would need to ensure are installed?

Thanks.

2
Cogs / Re: Getting opengl errors on linux.
« on: July 28, 2011, 12:24:05 AM »
@unhr,

Yeah, I tried out Rob's experimental binary that doesn't check for hardware capabilities and it didn't work on my hardware. It seems that Cogs's GPU requirements are reasonably high.

3
Cogs / Getting opengl errors on linux.
« on: July 27, 2011, 01:56:40 PM »
Hi,

I just bought cogs in the humble bundle 3 but it won't run on my Archlinux x86_64 machine. When I run it, I get the following error:

Warning: It appears that your hardware doesn't meet the minimum requirements necessary to run Cogs.  The following OpenGL extensions are unsupported: GL_ARB_vertex_shader, GL_ARB_fragment_shader, GL_EXT_texture_compression_s3tc

If I run glxinfo, the first two (the GL_ARB...) extensions are present, but not GL_EXT_texture_compression_s3tc. Do I need some particular library to make this available?

I'm using an integrated intel chipset, with the "intel" driver.

Thanks in advance,

Pete.

Pages: [1]